Showing results 1 to 3 of 3

Thread: Physical CD drive missing from explorer

  1. #1

    Default Physical CD drive missing from explorer

    Installed fine and actually played a few games.
    I notice however that my CD-RW drive was missing from explorer (drive letter replaced by a virtual drive). After modifying the drive letter to be past the normal set of drives and rebooting, it did not re-appear. My regular DVD drive never had a problem. Tried a bunch of things to get it back short of messing with the Registry. XP DOES see the drive (I can read a CD from within CloneCD for example). The drive is working properly, but it will NOT show up in explorer and will not autorun a CD. I tried the following, none of them restored the drive:
    - Remove daemon and reboot
    - Remove both drives from system and reboot (removed cable)
    - Put just the CD-RW back and boot up
    - Put both back
    - Re-Install daemon without the physical drives and mess with the drive letters
    - Put just the CD-RW back and boot up (daemon still installed)

    I can go into Device Manager and see the CD-RW drive as well as the other drives (DVD and virtual) and all look good.
    I am not able to change the drive letter anywhere. I know I did this once before, but for the life of me am not able to do it again.

    The problem drive is a YAMAHA CRW2200E running with the base XP drivers on a AMD 1.4 system. No other CD related apps running (I disabled all the startup crap from Nero and Clony and all those).

    So, what am I missing? Any suggestions would be appreciated.

  2. #2

    Join Date


    Disabling applications at startup will not help - you must competely unnstall them to remove their drivers from system, if any.
    Do you use Nero InCD?

  3. #3


    I do no use InCD or anything else at startup that would grab the CD drive.
    (Read this as no startup apps. I removed any registry startup entries associated with cd-burning software.)

    I did get the problem resolved however. I shutdown and swaped the cabeling (i.e. Moved the problem drive from the Primary IDE channel to the secondary one). This solved the problem. XP saw it as a new device and re-installed it all together. Just like Windows does if you move a card from one slot to another. XP must have remembered the drive where it was even when I removed the cabel, but I never plugged the cabel into anything else on my previous tests (I know this, but just didn't remember it until after I posted :roll. Anyway, cabels are back to there original position and both drives are now present. I do not have daemon loaded at all because of this problem. However, I would like to keep using it. I think once the change to not have the drive letters automatically be before any hardware CD drives will solve the problem. I would like to know what may have caused the problem, just out of curiosity if nothing else.

    Nice job on the tool. Keep up the good work.


Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts