Page 1 of 12 12311 ... LastLast
Showing results 1 to 10 of 113

Thread: "System File Error" when installing 4.0

  1. #1

    Default "System File Error" when installing 4.0

    I had 3.47 on my system for a long time... no problems. I upgrade to 4 it removes the old on, all its assoicated drives go away and from device manager but when it gets to installing the SPTD install I get the System File Error.


    Anyone else get this?

  2. #2
    Administrator



    Join Date
    06.11.2002
    Posts
    2,044

    Default

    Setup has problems writing to registry in Services hive. Maybe registy permission problem.

  3. #3

    Default Registry issue

    Yes, it's a registry issue: HKLM\system\currentcontrolset\services\stpd\cfg is write protected. I could however not change the permission (being the administrator). Does anybody has an idea?


  4. #4
    Administrator



    Join Date
    06.11.2002
    Posts
    2,044

    Default

    Did you have this error from the very first setup attempt?
    It seems SPTD is already running on you system as it protects this key, but setup does not detect it somehow.
    Any errors in system event log?
    Try to delete sptd.sys and reboot (so it releases this key) then run setup again. What happens?
    If you still get same error immediately then some other application blocks access to registry in general.

  5. #5
    New User
    Join Date
    15.11.2005
    Posts
    9

    Default

    Where can I find this System event log? (I had the same problem, posted a thread about it, you asked me if there were any errors in my system event log)

    Maybe my Antivirus has something to do with it.

    <Z>

  6. #6

    Default

    Run eventvwr.msc
    Everybody be cool! You, be cool!
    They'll keep fighting! And they'll win!

  7. #7
    New User
    Join Date
    15.11.2005
    Posts
    9

    Default

    Says:

    Error - Source: sptd - Category: none - Event: 4 - User: N.A.


    0000: 00 00 00 00 01 00 52 00 ......R.
    0008: 00 00 00 00 04 00 04 c0 .......А
    0010: 04 00 00 00 00 00 00 00 ........
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........

    Says the driver found an internal error.

    <Z>

  8. #8
    Administrator



    Join Date
    06.11.2002
    Posts
    2,044

    Default

    This log just shows SPTD could not start after reboot but it WAS successfilly installed. I cannot understand then - when you got this System file error, at which point in installation?

  9. #9
    New User
    Join Date
    15.11.2005
    Posts
    9

    Default

    Not sure if my post got through (think the forums were closed right before I clicked the "Submit Reply" button last time)...

    [edit: It did get through, sry for double post]

    <Z>
    Last edited by Zembla : 16.11.2005 at 14:33

  10. #10

    Default

    Ive been having this same error each time I try to install DT v4. I deleted the sptd.sys file and rebooted. On restart I was able to modify the permission settings for the cfg folder in the registry (I hadnt been able to earlier) however the problem persists.

    I checked the event manager. There are a good number of errors, but none seem to be of any relation to DT as they dont chronologically align with my installation attempts.

    Ive been putting off a good 'ol reformat for a while now (never done it in 3 years), so maybe Ill do that and see if it does anything.

Page 1 of 12 12311 ... LastLast

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •