Page 9 of 9 FirstFirst ... 789
Showing results 81 to 88 of 88

Thread: "Failed to open config key" when installing 4.0.3

  1. #81

    Default SPTD open config file

    Just delete all info in registry, then delete drivers with SPTD in Windows/system32/drivers & anything to do with SPTD..

    Worked for me

    Because Like you lot I spent 2-4 hours messing about & then above worked..

    Delete info for software with deamon tools alcohol in registry....
    from run in start menu type regedit & then locate

  2. #82

    Default

    I copied this from your archives and Changed a few things to make the instillation easier.
    Have you ever gotten a "System File Error" or "Unable to open Config.sys" when installing Daemon Tools.

    This is how I got mine fixed.
    It has to do with the SPTD drivers and the dtsci.sys file.

    1. First unistall all virtual drives and DT along with Alcohol 120%.
    2. Open your Command Prompt type "cd\ "then enter and then type "cd windows\system32\drivers" and delete sptd.sys, sptdxxxx.sys [xxxx being a number]), and dtsci.sys files
    3. Then restart your pc.
    4. Run daemon tools installation file. It will then install the SPTD thing again and then restart the pc.
    5. The installation will then continue, follow the installation wizard and your up and running.

    After you have done the above you can install Alcohol 120% latest version. This took care of the config.sys, kernel, and sptd errors.
    Hope this helps. If it doesn't you can go to the archives and figuire out like I did. There are alot of solutions depending on your setup.

    http://www.daemon-tools.cc/dtcc/arch...hp/t-9327.html

  3. #83

    Reden

    It has to do with the SPTD drivers and the dtsci.sys file.

    1. First unistall all virtual drives and DT along with Alcohol 120%.
    2. Open your Command Prompt type "cd\ "then enter and then type "cd windows\system32\drivers" and delete sptd.sys, sptdxxxx.sys [xxxx being a number]), and dtsci.sys files
    3. Then restart your pc.
    4. Run daemon tools installation file. It will then install the SPTD thing again and then restart the pc.
    5. The installation will then continue, follow the installation wizard and your up and running.


    YES! I followed these steps and got my problem fixed . THx man!

  4. #84

    Default

    Quote Originally Posted by Underheaven
    The key has correct permissions. I recommend not changing them.
    First of all, thanks for all the posts. renaming the dtscsi.sys and sptd.sys, rebooting and then reinstalling Daemon Tools 4.03 got me up and running. After reading these posts and poking around, I have come to the following conclusion:

    On NT/2000/XP, the registry permissions for "[HKLM]\SYSTEM\CurrentControlSet\Services\sptd\Cfg" are INCORRECT in only having the local Administrators group access to the key and only having assigned the "Query Value" and "Set Value" permissions. This key should at minimum have "Delete" capability for proper re-installation or removal of the registry key as needed. If you are capable (experienced) of changing the permissions, I recommend setting this key to "Inherit" the permissions from is parent and set to have child objects permission replaced accordingly.

    Also, Daemon Tools 4.x installs the dtscsi.sys and sptd.sys drivers on our computers. Upon sucessful installation and reboot, the drivers are set to load by windows. As these drivers are loaded, they lock the above mentioned registry key. Daemon Tools upgrade or uninstallation needs to either disable the driver properly and/or remove (or prompt the user to remove) the drivers. Currenty, the drivers remain on our computers and get loaded even after Daemon Tools is uninstalled. During this situation, any attempts to update the "Cfg" registry key are foiled because the key is locked and/or because the only group having permission to this key has limited access (does not have read, write or delete).

    I believe that safe-mode update/removal may only work if you opt to not load the sptd.sys driver. This is done by pressing "Esc" during the safemode boot process. If you miss this, then the driver will be loaded in safe mode with the Cfg registry key locked with the same problem. I say "may" work because, i didnt actually observe that the sptdinst.exe tool helped me out. This may have been bacause it is sensible that the "sptdinst.exe remove" command probably attempts to remove the sptd registry key including the "Cfg" subkey - in which the "Administrators" group does not have "Delete" permission to.

    Hope this is helpful.
    Last edited by twstdpairs : 21.08.2006 at 23:48

  5. #85
    Master
    Jito463's Avatar
    Join Date
    24.05.2005
    Posts
    1,626

    Default

    Quote Originally Posted by twstdpairs
    On NT/2000/XP, the registry permissions for "[HKLM]\SYSTEM\CurrentControlSet\Services\sptd\Cfg" are INCORRECT
    Actually, it is correct. SPTD and Alcohol work perfectly on my system, but access to that reg key is still blocked. It's designed that way to avoid some blacklist methods. Unfortunately, it looks like some people may have to change that make it work on their system for who knows what reason. But to say it's set wrong is incorrect.

  6. #86

    Default

    Quote Originally Posted by Jito463
    But to say it's set wrong is incorrect.
    I think it is a mistake to set only one group of user to have access to a key and then greatly limit that key so that removal of the key (through registry cleanup tool or uninstall) is not possible without either changing the permissions manually or in some advanced automated way. So many people dont know how MS security works and develop programs that need to write user config to the wrong keys and wrong areas of a NTFS hard drive - the reason MS shipped the OS with everyone having Admin privileges - so much of the poorly developed applications function (not associating Daemon Tools as being poorly developed but there are plenty).

    I am quite familiar with MS security in the registry and say that it is indeed a blunder / wrong to set the permissions as stated.

    At runtime, sptd.sys itself takes care of locking / hiding the contents of the Cfg registry key - whether Administrators have full control or not. Accordingly, I see no reason to have one sole group linked to this key, who doesnt even have permission to delete the key. My local admins group now has 'full control' of that key, but still cant access the key when my computer is booted normally and sptd.sys loaded - maintaining the protection against blacklist methods.

    Ref: http://www.greatis.com/security/What...%23%23.sys.htm (a user should not have to go through this much pain for proper uninstallation)

    One last point: Software "working perfectly" to an end user, by no means account for the components that the software consists of as having been implemented in a "correct" manner.
    Last edited by twstdpairs : 23.08.2006 at 01:09

  7. #87

    Default

    Hello guys this is my first post and I just solved my problem after some tries. PLEASE READ THIS BEFORE DOING ANYTHING ELSE LIKE INSTALLING SPTD FROM COMMAND WINDOW (Especially to people that re-installed windows or anything like it). Thats what worked for me :

    Go to registry editor ( RUN -> regedit) in the location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd
    and double click to the "Start" value. For some reason mine was set to "0" it is supposed to be set to "1" in order to work!
    You can try everything that people in this forum suggests AFTER setting this value to "1"

    I really hope I helped some out there - excuse my english Good luck!

  8. #88

    Default ...

    Quote Originally Posted by Freakanomalos
    Hello guys this is my first post and I just solved my problem after some tries. PLEASE READ THIS BEFORE DOING ANYTHING ELSE LIKE INSTALLING SPTD FROM COMMAND WINDOW (Especially to people that re-installed windows or anything like it). Thats what worked for me :

    Go to registry editor ( RUN -> regedit) in the location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd
    and double click to the "Start" value. For some reason mine was set to "0" it is supposed to be set to "1" in order to work!
    You can try everything that people in this forum suggests AFTER setting this value to "1"

    I really hope I helped some out there - excuse my english Good luck!
    Beware that the value is supposed to be zero.
    the modern world:
    net helpmsg 4006

Page 9 of 9 FirstFirst ... 789

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •