I too could not install the last to two version without the error message, once I downloaded the 3.23 version before it would load without the error message.