Page 3 of 6 FirstFirst 12345 ... LastLast
Showing results 21 to 30 of 53

Thread: system hangs after installing sptd.sys

  1. #21


    I have tried all the tips on this site and I have installed the new SPTD, still no luck. But after reading about your logitech camera problems I tried unpluging my logitech cam and voila it booted no problem!

    Thanks guys
    I hope this works for more than one boot though hehehe

  2. #22


    After upgrading from DT 4.03 SPTD 1.24 to SPTD 1.25, i had the same well-known boot problems. Unplugging my USB racing wheel was without success, so i deleted all sptd entries out of the registry, installed DT 4.03 SPTD 1.24 and the boot problems are gone.

  3. #23

    Default ...

    Quote Originally Posted by zwiebeljack
    installed DT 4.03 SPTD 1.24 and the boot problems are gone.
    fyi: The latest version of DAEMON Tools comes with SPTD 1.25
    the modern world:
    net helpmsg 4006

  4. #24

    Default fix?

    There is a potential fix for this problem with the newly released Logitech Drivers from 8/22. More info can be found at the end of the thread here:

    I haven't tried it yet but I would hope it would fix our issue as well.

  5. #25

    Ausrufezeichen Maybe a fix for some?

    OK guys. I had this problems for a while and think I have come across a solution that will help some people.

    1. Restart in safe mode and let it try to load sptd.sys Let it hang for at LEAST 3 minutes before hitting esc.

    2. This should allow you to then hit escape and boot into windows in safe mode under admin.

    3. Run DT and "unmount all drives"

    4. restart computer in normal mode and NEVER shut down or restart with a virtual cd in the drive.

    If the above doesn't work try this first:

    1. Go into "C:\windows\system32\drivers" and delete the sptd.sys and sptdXXXX.sys files.

    2. Reinstall those files using the installer on the downloads page.

    3. take the above mentioned steps.

    If THAT doesn't work then your just going to have to try whatever you can do to get DT to run in safe mode. The problem in my case seems to be that my computer DOES NOT like for a cd to be in the virtual drive when I restart. Once I unmount that cd in safe mode the gods of computer troubleshooting smile on me.

    Hope this helps,
    Good luck

  6. #26
    New User
    Join Date


    I just started having this issue today... D-tools 3.47 errors on on the similar .sys file (the d3* one)...

    Was there a windows update that decided to re-break this?

    I'm running windows XP SP2... Unfortunately none of these fixes helped :/ I've been rebooting/deleting in safe mode for about 30 minutes now.

  7. #27


    I'm happy to report an possible alternative fix. Only if you're using SATA drives only.

    If you're using SATA drive(s), uninstalling IDE controllers drivers from the device manager solved my problem - they weren't being used.

    In the "IDE ATA/ATAPI Controllers", uninstall IDE Primary, Secoundary and the IDE Parallel/Dual thing if you've got them installed..

    This solved my 30 second extra loading time.

  8. #28

    Default roxizap - find it try it worked for me


  9. #29


    Quote Originally Posted by DezLint
    My machine wasnt booting after i installed DT, so i went through trying to fnd out what was conflicting with the SPTD.sys.

    Finally after a couple of hours unplugging things i found that my logitech webcam pro 5000 was to blame, if i have the webcam plugged in my machine wont boot, if i unplug it the machine will boot on the other hand if i remove SPTD.sys i can boot my machine with my webcam in.

    I was wondering if anyone else has found this or what would be better if anyone knows a fix for this?

    Hello, I just wanted to register to post and confirm that there is indeed some sort of confliction between the Logitech Quickcam Pro 5000 and sptd.sys.

    Right after the XP boot screen my system would hang, never making it to the login screen. The problem wouldnt appear right away, but did eventually. Forcing the system to reboot resulted in receiving the error message "We apologize for the inconvenience, but Windows did not start successfully Attempting to boot normally or to restore the last known good configuration would do no good, the system would still hang.

    I initially suspected that the Logitech webcam drivers were causing the problem, but I was skeptical because they had never caused a problem before. I had downloaded the newest version from Logitechs site so I tried the version on the CD. On both sets, the system hung before the login screen.

    I did a fresh install of XP and tried to reproduce the problem by installing the Logitech drivers first. The system made it through twelve reboots.

    Long story short, I finally figured out that sptd.sys was causing the problem and uninstalled Daemon Tools and deleted sptd.sys and sptdxxxx.sys. After that, I havent had any problems with booting.

    After finding this thread and seeing the post about the webcam I decided to try and reproduce the problem. I had not removed the Quickcam drivers since taking off Daemon Tools earlier so I just reinstalled the latest version of DT. Not surprisingly, the system hung on boot. I hard rebooted and unplugged the camera and low and behold my system booted right up.

    Solution: As the previous poster said, DT and the Logitech webcam software can both be installed at the same time, but the system might hang if the camera is plugged in on boot. To solve this, simply plug the camera in at the login screen.

    I have tried both 4.03HE and 4.06 (which come with different versions of sptd.sys) today and both hang my system while the camera is plugged in. Whats strange is, my previous install of XP with webcam drivers and 4.03HE had no problems, but over the course of eight formats in the last two days (trying to solve this problem) the problem has consistently shown up and since become reproducible.

  10. #30


    Hi guys,

    I have exactly the same problems on my HP nx6325 laptop with AMD Turion 64 X2. XP boots and hangs right on the login screen There is definitely something wrong with this driver I noticed that if I manage to disable or enable wireless card during boot up with quick launch buttons - XP boots just fine:/ I have freshly installed XP Sp2 system. And I do not have any logitech products attached to my laptop.

Page 3 of 6 FirstFirst 12345 ... LastLast


Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts