Page 1 of 6 123 ... LastLast
Showing results 1 to 10 of 53

Thread: system hangs after installing sptd.sys

  1. #1

    Lächeln system hangs after installing sptd.sys on nForce4 boards

    I figured out why my system always hangs when trying to load sptd.sys.

    my config:
    nVidia nForce 4 Chipset (driver ver. 6.69)
    S-ATA II Harddisk
    daemon-tools 4.03 x64

    The problem is Native Command Queuing - after disabling it daemon-tools works just fine.

  2. #2


    Thx for the info.
    Everybody be cool! You, be cool!
    They'll keep fighting! And they'll win!

  3. #3
    New User
    x3r0's Avatar
    Join Date


    Doubtful that this is a clear fix.
    Most people I see reporting this only temporarily helps on some occasions. I had Daemon tools working fine for a few days and now my system hangs before login. I've tried everything everyone said.

    I'm not sure if I should blame NVidia or Daemon-Tools, I use Daemon-Tools like I couldn't live without, this is going to be hard for me to do without.

  4. #4


    I am wondering if you have the same configuration and have already tried to disable that special mode on your system? Do you not want to try the programs ncqoff or ncq-fix?

  5. #5
    New User
    Join Date


    Maybe I have a second idea on solving this problem.

    I recently had the same sptd.sys bug (no proper restart possible).

    My system run perfectly with 2 onboard IDE, 1 SCSI pci and 1 RAID pci controller, SW:EaW and CureRom etc.

    I changed my burners firmware and everything stopped.

    No solution offered here worked.

    I searched the registry and found 4 (four) entries regarding sptd.sys. I deleted all and reinstalled the sptd.sys.
    I researched the registry and found (as expected) only 2 entries for sptd.sys.

    System booted up properly. Everything is fine again


  6. #6

    Default Fix that worked for me

    I found a fix! Nothing else on these forums provided me with a solution to this problem, but after some extensive tinkering I found a way to do it. Here is a link to a short page I made with the steps to solving the problem:

    Hope this works
    Last edited by 0600Zulu : 06.03.2006 at 00:43

  7. #7
    New User
    Join Date


    Doesn't work for me,
    some of the registry reappear after deleted(Even though not installed)
    and Windws always makes sure that there's a scsiport.sys inplace(the file I have renamed apear with the original file)

  8. #8


    Just to confirm there is a problem--hanging just before switching to to the login ``page''.

    For me it seams as if the hang occurs randomly. Sometimes I need to reset to computer once or twice, but then it will come up.

    Mobo: ASUS A8N-E, nForce4 Ultra
    SMB + Eternet drivers installed (no firewall)
    CPU: AMD 3500+
    GPU: ASUS ATI X1600XT (fanless)
    DISKS: Western Digital Sata II
    Maxtor DiamondMax 10 Sata II

    Have not yet tried the NCQ disable ``fix''.

  9. #9
    New User
    Join Date

    Default NCQ fix

    Hi man,

    Do u still have the ncq fix ?
    or do u know where i can find it ? it s no more available in the nvidia site

  10. #10
    New User
    Join Date

    Default sptd.sys problems

    I am also having problems with sptd.sys. I have been running the Daemon tools under Windows 2003 Server x64 for a few days now. I wanted to try to install the tools on a B2 version of Vista x64 that I have. Vista refuses to boot with sptd.sys installed. The error message specifically calls out sptd.sys. This is either an incompatibiliy with Vista or as was mentioned below modifying the disk drivers. I am not sure which. Anyone else been able to install x64 version of Daemon Tools on Vista?

    Thank you.


Page 1 of 6 123 ... LastLast


Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts