No announcement yet.

Securom v7 Problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • Securom v7 Problems

    I don't know where best to ask help for this, but you lot know stuff about copy protections... well anyway I have this problem where flatout 2 and titan quest (both securom v7) won't run with their original exes. Flatout 2 just plain crashes, and titan quest does nothing after running it.

    These games were working, but after i did a windows update they broke. Anyone know how to uninstall/reinstall securom v7?

    These games both work with the nocd patches BTW. But still this is bugging me.

  • #2
    If you've problems running your games, you should contact the related support.
    Everybody be cool! You, be cool!
    They'll keep fighting! And they'll win!


    • #3
      Same here!! Titan & CivCity works fine... until the last patch day of XP!! Neither the Dark Messiah demo work... the mouse pointer hang on 1 or 2 sec with busy icon and then nothnig!!
      Any suggestion?


      • #4
        There was a recent windows patch that screwed with how windows lets programs access .ini files

        There was a bit of a controversy because Battlefield 2142 has a readme in a patch they did for BF2142 that says to remove the windows patch.

        Players who have the Windows security update KB917422 installed may suffer from an application error when running Battlefield 2142. This error can be solved by uninstalling the KB917422 update.
        I belive there's also an updated patch from MS if you dont want to just remove it, it says it fixes a stack problem in KB917422

        Anyway, you may need to do some research, there may be some workarounds as well.

        Also this may not be your problems, but that reminded me of that BF2142 controversy since its said to affect other games as well (the windows patch).

        I came across this thread in a search heh sorry to bump it, but they didn't respond to say if they fixed it, and I knew about the recent patch thing.