No announcement yet.

unable to mount from command line

  • Filter
  • Time
  • Show
Clear All
new posts

  • unable to mount from command line

    I have the latest version of DT and SPTD installed and running. Everything works fine except for mounting an image from the command line. From the help file it shows it should be something like this...

    daemon.exe -mount0."C:\imagename.iso"

    But it keeps on giving me an "unknown switch in command line" error. What am I doing wrong?

  • #2
    Try to replace the dot (".") with a comma (","). And ensure there is a space after mount and the device number.
    daemon.exe -mount 0,"C:\imagename.iso"
    Everybody be cool! You, be cool!
    They'll keep fighting! And they'll win!


    • #3
      Ah, thank you very much! The online help files should be updated to reflect this.


      • #4
        The online help is perfect regarding this:
        Example: daemon.exe -mount 0,"c:\My Images\nameofimage.cue".
        Everybody be cool! You, be cool!
        They'll keep fighting! And they'll win!


        • #5
          Quick question which is sort of related so I thought I'd reply here instead of creating a new thread...

          I've successfully mounted an image from a command line but I get a dialogue box saying "Secure mode confirmation for command line: -mount 0, C:\Test\Test.cue"; Yes or No...

          Is there a way to turn this off? I would really like no user interaction if possible when mounting an image.

          I tried adding -securom on before or after the -mount but that just gives another dialogue box; Yes or No.

          Your help is much appreciated


          • #6
            If you are using DT Lite you can disable secure mode through the options.
            Make something idiot proof, but then they just make a better idiot
            Peace Through Power


            • #7
              SecuRom is NOT what you are looking for to acomplish this. What you need to do is right click on the DT sys tray icon, go to Options, and turn off the "Secure mode" option, This will stop the nagging command line mount popups.



              • #8
                daemon command line in network fail


                I developed a script that mount a image file *.iso in remote computer with help of psexec of pstools.

                Simple run a script with the next command:

                psexec \\computer -c -d -s -i daemon.bat

                daemon.bat containts next line:

                CD "D:\Archivos de Programa\DAEMON Tools\"
                daemon.exe -mount 0, M:\ILEX\disco-azul.iso

                The M: is a network mapped folder from another computer (server).

                If i mount to hand in the icon try and use M:\ILEX\disco-azul.iso work fine, but from command line dont work, display next error:

                Unable to mount image. Invalid image file

                S.O of server: Windows XP SP2 Professional
                S.O. of client: Windows XP SP2 Professional

                I hope to can help me with this problem


                • #9
                  @uNk : Remove the space after the comma
                  the modern world:
                  net helpmsg 4006


                  • #10
                    I check to remove the (",") comma from line, but dont work either.

                    I put an image of error and you can see the line command send.

                    Details of daemon version:

                    - Daemon version: 4.09E
                    - SPTD version: 1.50
                    - Secure mode: OFF
                    - Automount: ON
                    - InUsecheck: OFF
                    - AutoStart: ON
                    - Tray icon: ON
                    - Check for updates: ON

                    Thanks and best Regards


                    • #11
                      Please update to latest Daemon Tools version, and check if mounts ok.
                      Everybody be cool! You, be cool!
                      They'll keep fighting! And they'll win!


                      • #12
                        FIX PROBLEM

                        I try all options, but the problem happend when the network drive is already connect and try mount an image from command line.

                        The problem fix when i disconnect network drive and connect from .BAT too with net use driveletter: \\computer\shared /user:user /persistent:no

                        If the .BAT run all process work fine, but if network drive already mounted and .BAT only use the -mount parameter for daemon dont work. Cant mount an image

                        Thanks for your time and i hope this answer help another people.