No announcement yet.

Playing genuine DVD games seems not to work any more.!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Playing genuine DVD games seems not to work any more.!

    Greetings everyone,
    i seem to have a slight problem since i installed Daemons Tools recently. Playing genuine DVD games seems not to work any more.
    For example..
    I have the original Crysis DVD which worked fine before DT.
    Now when i insert the dvd the 'autoplay' kicks in BUT after i press play nothing happends..same with COD4.

    So i searched the web and thought i found a way..where you have to delete the 'Upperfilters'..which i did but still no luck.

    I inserted a movie DVD just to see if that is gone too but the movie works fine no probs there...

    so just the games will not kick in...

    anyone has a clue on this for me please?

    Thanks folks in advance for your advice..


  • #2
    Hi everyone...
    a few days ago i downloaded 'Daemon Tools' and ever since my DVD Rom drive is not working anymore when i try to play genuine DVD games.

    For example i tried it with 'Crysis and COD4'..
    i insert the DVD into the drive and the auto play feature comes up...
    i press 'play' then the first 'start screen' appears where you press play etc...
    I press play again..the screen disappears and that is it.!!! will not kick clue why..!!

    Just to see if it's a DVD Rom failure i inserted a DVD movie to see if that works and it's is all good and it's only with games.
    I went to their website forum to see if I'm the only one but all their advise is of no help.
    Some said that i have to delete the 'upper filter' in the 'reg edit' which i did but it did not work...

    Just earlier i deleted 'Daemon Tools' completely as i hoped that this will fix it again but no..

    Now I'm stuck and i can't plat DVD games anymore on my PC...

    Anyone out there who can give me some advise please???

    Many thanks and best regards.



    • #3
      I deleted DT and REMOVED SPTD-DRIVER but still no luck....

      ANYONE HERE????....
      I Like my computer back as it was before i got this forsaken DT

      sure will never use DT ever again in future...


      • #4
        If you removed DTools and SPTD, then they can no longer have any affect on your system, though I doubt they ever actually caused any problems in the first place. Many other people have used DTools for years and never encountered the problem you're describing. I'd help you if I could, but since I have no clue what could have caused your issue in the first place, I wouldn't know where to start.


        • #5
          same thing happend for me.
          ive tried to delete every trace of daemon tools.
          and games still dont work.
          its ridiculous.


          • #6
            Originally Posted by TonyM View Post
            I deleted
            Originally Posted by JJFLIP182 View Post
            tried to delete
            Install/reinstall the latest DT & then JUST use the UNISTALL, that's what it's there for.. Don't DELETE anything manually... Probably you could use YASU, just place it in the DT installation directory, launch it & use cloak:


            ...let us know if it works.


            • #7
              i reinstalled and then unistalled. The game still does not work.
              What is Wasu?


              • #8
                Which game(s) ?
                Which error meassage do you get ?

                Have you also uninstalled SPTD driver ?
                Run SPTD Installer and choose Uninstall.
                I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.


                • #9
                  My brother had that problem on his dell laptop. He couldnt fix it until he did a complete system recovery.


                  • #10
                    JJFLIP182, the newest YASU is here.



                    • #11
                      If you strugle using Yasu you can go to the curecom and yasu support section also you can try a system restore(which you can find Start-> control panel->performance and maintenance -> sytem restore) on the date DT was installed(windows automatically creates one before theSPTD driver is installed).
                      Never cross a bridge until you come to it