Page 1 of 2 12 LastLast
Showing results 1 to 10 of 14

Thread: yasu -s doesn't work for me

  1. #1

    Default yasu -s doesn't work for me

    Yasu works as expected on my system if I don't use -s.

    However, if I enter yasu -s from a command prompt, it does nothing. Yasu does not start (I can tell by running Yasu normally; it starts rather than stops).

    If I put yasu -s in a batch file, the batch file fails to move to the next line.

    Any ideas?

    Thanks!

  2. #2

    Default

    Have you tried creating a shortcut to yasu.exe with the -s parameter?
    CureROM Support Team

  3. #3

    Default

    Have not tried that because what I'm trying to do is make a batch file work. However, I did try yasu -a, and that works, even though it does yasu -s at startup.

    So somehow yasu -s is not compatible with my XP command prompt environment.

  4. #4
    Experienced User

    Join Date
    27.09.2005
    Posts
    822

    Default

    could be related to parsing the commandline
    from console based programs, i've seen the ' character used instead of " , and sometimes no character at all

    maybe syk0 could shed some light on it, or debug yasu and bpx on GetCommandLineA and see what happens

  5. #5
    Experienced User
    sYk0's Avatar
    Join Date
    27.12.2005
    Posts
    392

    Default

    If I put yasu -s in a batch file, the batch file fails to move to the next line.
    In a commandline enviroment when you run YASU (even without -s) YASU runs properly, however the command prompt is waiting for YASU to exit/close before continuing to the next line.

    I'll look at fixing this "bug" in YASU 1.1.0
    Mail:
    curerom @ daemon-tools.cc

  6. #6

    Default

    Thanks.

    BTW, one other thing I've noticed:

    if you start yasu silently with yasu -a, the first time you run yasu manually it silently restores your drives if you don't use -s

  7. #7
    Experienced User
    sYk0's Avatar
    Join Date
    27.12.2005
    Posts
    392

    Default

    Just so you know with Y.A.S.U v1.1.0 there will be various fixes and additions to the commandline parameters, this shoud make use of Y.A.S.U a bit easier to use from scripts/batch file(s).

    If I put yasu -s in a batch file, the batch file fails to move to the next line.
    However there is a solution to the above probelm.
    When running a 32bit application (i.e Y.A.S.U) from a script/batch file try the following example.

    ================================================

    @ECHO OFF
    @ECHO Step 1: Run Y.A.S.U, cloak your devices.
    @START YASU.exe -s

    @ECHO Step 2: Run your Application/game.
    @"D:\Games\Star Wars Empire at War\GameData\sweaw.exe"

    @ECHO Step 3: Run Y.A.S.U, uncloak your devices.
    @START YASU.exe -s

    @rem Remove the line below to disable pause in scipt.
    @pause
    Mail:
    curerom @ daemon-tools.cc

  8. #8

    Default

    Nice.
    How far off is 1.1.0 now?

  9. #9

    Default

    Thanks. The start command does help.

    However, I then found a new problem, at least for Forces of Corruption (swfoc.exe). It seems to return control to the batch file too soon! Even if I use start /wait, the batch file proceeds almost immediately, so that yasu unloads too soon. From googling, this may be because it's multithreaded.

    Anyway, I found a fix: I downloaded the Microsoft batch command sleep.exe, and added sleep 30 to insert a 30 second delay after launching swfoc and before unloading yasu. This seems to be enough.

  10. #10
    Experienced User
    sYk0's Avatar
    Join Date
    27.12.2005
    Posts
    392

    Default

    However, I then found a new problem, at least for Forces of Corruption (swfoc.exe). It seems to return control to the batch file too soon! Even if I use start /wait, the batch file proceeds almost immediately, so that yasu unloads too soon. From googling, this may be because it's multithreaded.
    This has something to do with SecuROM, with the newer versions of SecuROM when you run your game (swfoc.exe) the SecuROM wrapper kills the process then starts a new one, that's why you batch file moves to the next line (the procces ended).
    Mail:
    curerom @ daemon-tools.cc

Page 1 of 2 12 LastLast

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •